Globedia.com

×
×

Error de autenticación

Ha habido un problema a la hora de conectarse a la red social. Por favor intentalo de nuevo

Si el problema persiste, nos lo puedes decir AQUÍ

×
cross

Suscribete para recibir las noticias más relevantes

×
Recibir alertas

¿Quieres recibir una notificación por email cada vez que Sirca escriba una noticia?

Fórmula para sacar Curp en excel

19
- +
29/10/2020 03:32 0 Comentarios Lectura: ( palabras)

Aprende la formula para calcular tu CURP o la de cualquier persona en excel de manera fácil y sencilla

La Curp es la Clave Única de Registro de Poblacion que identifica a todos y cada uno de los ciudadanos de México así como a los extranjeros que residen en el país. 

Este número de identificación es obligatorio y único, y está formado por una serie de caracteres alfanuméricos que podemos sacar si sabemos cómo hacerlo.

Si necesitas tu curp para algún trámite, puedes obtener tu CURP gratis, pero hay ocasiones en las que necesitamos sacar el curp de varias personas a través de sus datos personales. Para ellos, aquí explicamos como hacerlo a través de un sencillo excel.

 

Cómo se calcula la Curp

La Curp está compuesta por 18 caracteres sacados de diferentes datos personales de la persona titular.

Estos son: 

- Nombre

- Apellidos

- Fecha de nacimiento

- Lugar de Nacimiento

- Sexo

Con estos datos se puede calcular la CURP.

De estos 18 caracteres:

- El primer y segundo caracter se saca de la inicial y la primera vocal del primer apellido. 

- El tercero es la inicial del segundo apellido

- El 4º es la inicial del nombre principal

- Del 5º al 10º usamos la fecha de nacimiento, colocando primero el año, después el mes y por último el día

- El 11º será una H o una M dependiendo de si es hombre o mujer

- El 12º y 13º es la abreviatura del estado del lugar de nacimiento

- El 14º es la primera consonante no inicial del primer apellido

- El 15º es la primera consonante no inicial del segundo apellido

- El 16º es la primera consonante no inicial del nombre 

 

Los dos últimos dígitos son los digitos verificadores, conocidos como la homoclave. Estos los genera el sistema para evitar que pueda haber dos número de CURP iguales. 

Con esta fórmula de excel, podrás calcular todas las CURP que quieras en segundos

Hacerlo de manera manual puede ser un poco tedioso, sobre todo si necesitamos calcularlo de varias personas a la vez.

Por ello, os mostramos la fórmular con la que poder hacerlo de manera rápida y sencilla desde un excel. 

Vamos a ver cómo hacerlo.

 

Fórmula para sacar la Curp en excel

Como vemos, la curp se puede calcular ya que se extrae de los datos personales de cada uno. Por ello, podemos realizar una fórmula de excel capaz de calcular esta Clave a través de los datos personales que introduzcamos.

 

Si escribieramos los datos en las celdas tal como vemos en la imagen, la fórmula a utilizar en la celda en la que queremos que se genere la curp sería:

=SI(CONTARA(A2:F2)<>6;"";CONCATENAR(N2;O2;P2;Q2;R2;S2;T2;U2;V2;W2;X2;Y2;Z2;SI(AA2="Ñ";"X";AA2);SI(AB2="Ñ";"X";AB2);SI(AC2="Ñ";"X";AC2);AD2;AE2))

 

Esta formular corresponde a los datos de las celdas de la fila 2.

Para la fila 3 la fórmula sería: 

=SI(CONTARA(A3:F3)<>6;"";CONCATENAR(N3;O3;P3;Q3;R3;S3;T3;U3;V3;W3;X3;Y3;Z3;SI(AA3="Ñ";"X";AA3);SI(AB3="Ñ";"X";AB3);SI(AC3="Ñ";"X";AC3);AD3;AE3))

 

Y así sucesivamente, cambiando el número de la fórmula por el de la celda que corresponda. 

Otra manera más fácil es, una vez tengamos hecho el cálculo con los datos de la fila dos, copiar la celda donde se genera la curp al resto de filas. De esta manera, se realizarán todas ellas automáticamente.

Con estas fórmulas puestas, ya podems introducir los datos de cada persona o modificar los que ya están, y el número de curp se generará automáticamente en la celda del excel correspondiente. 

Con este excel podrás calcular tantas curp como necesites. 


Sobre esta noticia

Autor:
Sirca (2 noticias)
Visitas:
340
Tipo:
Tutorial
Licencia:
Distribución gratuita
¿Problemas con esta noticia?
×
Denunciar esta noticia por

Denunciar

Comentarios

Aún no hay comentarios en esta noticia.